Welcome to the AIRSOCIETY | Air Suspension Forum.
Results 1 to 5 of 5

Thread: Bit of a pickle..again

              
   
   
  1. #1
    Spring Hacker
    Join Date
    Nov 2011
    Location
    Rockville MD
    Posts
    83
    Post Thanks / Like

    Bit of a pickle..again

    Soooo, I was messing around with the GoPro my girlfriend got me for my birthday, driving around my neighborhood and shooting random video. Parked the car, aired it out. Went back to it about an hour later and had no display on my Easy Street V1 controller. Popped the trunk, little red light don't flash. Checked power going to ECU, 12.75 volts. Checked ground, good. Decided to try individually giving power to each valve to try and raise the car to move it, and when I do that the ecu kicks on and the red light flashes 2 times per second but nothing happens. Car is stuck on the frame in front of my neighbors house....the V1 is only a few months old...help? Thanks

  2. #2
    Site Sponsor Forjworks
    Join Date
    Nov 2010
    Location
    Honolulu, Hawaii, United States
    Posts
    1,365
    Post Thanks / Like
    Common problem. We had that happen a few times with customers car.. Just ask for a new one. and hope it dont happen again.
    Last edited by eight08customs; 05-07-2012 at 09:47 PM.


    Dont forget to like us on Facebook
    https://www.facebook.com/AirRexAirSuspension

    Instagram
    @airrexusa

    www.airrexus.com

  3. #3
    Spring Hacker
    Join Date
    Nov 2011
    Location
    Rockville MD
    Posts
    83
    Post Thanks / Like
    Bad ECU as I suspect?

  4. #4
    Spring Hacker
    Join Date
    Nov 2011
    Location
    Rockville MD
    Posts
    83
    Post Thanks / Like
    Just used a power probe to air the car up and move it into my driveway. FML

  5. #5
    Spring Hacker
    Join Date
    Nov 2011
    Location
    Rockville MD
    Posts
    83
    Post Thanks / Like
    Air lift is sending me a new ECU, i even asked politely and they are sending me a 145psi ecu instead of the 175 that I have. Thumbs up for good customer support

 

 

Visitors found this page by searching for:

easy street v1 ecu flashes red light

SEO Blog

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •